CC_CUBIC(4FREEBSD) - Linux man page online | Special files
CUBIC Congestion Control Algorithm.
September 15, 2011
CC_CUBIC(4) BSD Kernel Interfaces Manual CC_CUBIC(4)
BSD September 15, 2011 BSD
NAMEcc_cubic — CUBIC Congestion Control Algorithm
DESCRIPTIONThe CUBIC congestion control algorithm was designed to provide increased throughput in fast and long-distance networks. It attempts to maintain fairness when competing with legacy NewReno TCP in lower speed scenarios where NewReno is able to operate adequately. The congestion window is increased as a function of the time elapsed since the last conges‐ tion event. During regular operation, the window increase function follows a cubic func‐ tion, with the inflection point set to be the congestion window value reached at the last congestion event. CUBIC also calculates an estimate of the congestion window that NewReno would have achieved at a given time after a congestion event. When updating the congestion window, the algorithm will choose the larger of the calculated CUBIC and estimated NewReno windows. CUBIC also backs off less on congestion by changing the multiplicative decrease factor from 1/2 (used by standard NewReno TCP) to 4/5. The implementation was done in a clean-room fashion, and is based on the Internet Draft and paper referenced in the SEE ALSO section below. MIB Variables There are currently no tunable MIB variables.
SEE ALSOcc_chd(4), cc_hd(4), cc_htcp(4), cc_newreno(4), cc_vegas(4), mod_cc(4), tcp(4), mod_cc(9) Sangtae Ha, Injong Rhee, and Lisong Xu, CUBIC for Fast Long-Distance Networks, http://tools.ietf.org/id/draft-rhee-tcpm-cubic-02.txt. Sangtae Ha, Injong Rhee, and Lisong Xu, "CUBIC: a new TCP-friendly high-speed TCP variant", SIGOPS Oper. Syst. Rev., 5, 42, 64-74, July 2008.
ACKNOWLEDGEMENTSDevelopment and testing of this software were made possible in part by grants from the Free‐ BSD Foundation and Cisco University Research Program Fund at Community Foundation Silicon Valley.
HISTORYThe cc_cubic congestion control module first appeared in FreeBSD 9.0. The module was first released in 2009 by Lawrence Stewart whilst studying at Swinburne Uni‐ versity of Technology's Centre for Advanced Internet Architectures, Melbourne, Australia. More details are available at: http://caia.swin.edu.au/urp/newtcp/
AUTHORSThe cc_cubic congestion control module and this manual page were written by Lawrence Stewart <@FreeBSD.org> and David Hayes <@ieee.org>.
|This manual||Reference||Other manuals|
|cc_cubic(4freebsd)||referred by||cc_cdg(4freebsd) | cc_chd(4freebsd) | cc_dctcp(4freebsd) | cc_hd(4freebsd) | cc_htcp(4freebsd) | cc_newreno(4freebsd) | cc_vegas(4freebsd) | CCV(9freebsd) | DECLARE_CC_MODULE(9freebsd) | mod_cc(4freebsd) | mod_cc(9freebsd)|
|refer to||cc_chd(4freebsd) | cc_hd(4freebsd) | cc_htcp(4freebsd) | cc_newreno(4freebsd) | cc_vegas(4freebsd) | mod_cc(4freebsd) | mod_cc(9freebsd) | tcp(4freebsd)|