IPHETH(4FREEBSD) - Linux man page online | Special files
USB Apple iPhone/iPad tethered Ethernet driver.
November 24, 2015
IPHETH(4) BSD Kernel Interfaces Manual IPHETH(4)
BSD November 24, 2015 BSD
NAMEipheth — USB Apple iPhone/iPad tethered Ethernet driver
SYNOPSISTo load the driver as a module at boot time, place the following line in loader.conf(5): if_ipheth_load="YES" Alternatively, to compile this driver into the kernel, place the following lines in your kernel configuration file: device uhci device ohci device usb device miibus device uether device ipheth
DESCRIPTIONThe ipheth driver provides support for network access through Apple iPhone and iPad devices, often referred to as USB tethering. ipheth should work with any Apple iPhone or iPad device. In most cases this must be explic‐ itly enabled on the device first. For more information on configuring this device, see ifconfig(8). The device does not sup‐ port different media types or options.
HARDWAREThe following devices are supported by the ipheth driver: · Apple iPhone tethering (all models) · Apple iPad tethering (all models)
SEE ALSOarp(4), cdce(4), intro(4), netintro(4), urndis(4), usb(4), ifconfig(8), usbconfig(8)
HISTORYThe ipheth device driver first appeared in FreeBSD 8.2.
AUTHORSThe ipheth driver was written by Hans Petter Selasky <@FreeBSD.org>.
BUGSSome devices may need to be manually configured to use an alternative configuration with the usbconfig(8) utility. A command similar to usbconfig -u 1 -a 2 set_config 3 may be required if the device is not recognised automatically by ipheth after it is con‐ nected.
|This manual||Reference||Other manuals|
|ipheth(4freebsd)||referred by||cdce(4freebsd) | if_cdce(4freebsd) | if_ipheth(4freebsd) | if_urndis(4freebsd) | urndis(4freebsd)|
|refer to||arp(4freebsd) | cdce(4freebsd) | ifconfig(8) | intro(4) | netintro(4freebsd) | urndis(4freebsd) | usb(4freebsd)|