URNDIS(4FREEBSD) - Linux man page online | Special files
USB Remote NDIS Ethernet device.
November 24, 2015
URNDIS(4) BSD Kernel Interfaces Manual URNDIS(4)
BSD November 24, 2015 BSD
NAMEurndis — USB Remote NDIS Ethernet device
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device ehci device uhci device ohci device xhci device usb device miibus device uether device urndis Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_urndis_load="YES"
DESCRIPTIONThe urndis driver provides Ethernet access over Remote NDIS (RNDIS), allowing mobile devices such as phones and tablets to provide network access. It is often referred to as USB teth‐ ering, and in most cases must be explicitly enabled on the device. urndis should work with any USB RNDIS devices, such as those commonly found on Android devices. It does not support different media types or options. For more information on configuring this device, see ifconfig(8).
HARDWAREThe urndis driver supports the "tethering" functionality of many Android devices.
SEE ALSOarp(4), cdce(4), ipheth(4), netintro(4), usb(4), ifconfig(8)
HISTORYThe urndis device driver first appeared in OpenBSD 4.7. The first FreeBSD release to include it was FreeBSD 9.3.
AUTHORSThe urndis driver was written by Jonathan Armani <@openbsd.org>, Michael Knudsen <@openbsd.org>, and Fabien Romano <@openbsd.org>. It was ported to FreeBSD by Hans Petter Selasky <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|urndis(4freebsd)||referred by||cdce(4freebsd) | if_cdce(4freebsd) | if_ipheth(4freebsd) | if_urndis(4freebsd) | ipheth(4freebsd)|
|refer to||arp(4freebsd) | cdce(4freebsd) | ifconfig(8) | ipheth(4freebsd) | netintro(4freebsd) | usb(4freebsd)|