UBSA(4FREEBSD) - Linux man page online | Special files
USB support for Belkin serial adapters.
April 26, 2017
UBSA(4) BSD Kernel Interfaces Manual UBSA(4)
BSD April 26, 2017 BSD
NAMEubsa — USB support for Belkin serial adapters
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device usb device ucom device ubsa Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): ubsa_load="YES"
DESCRIPTIONThe ubsa driver provides support for the USB-to-RS232 Bridge chip used by a variety of serial adapters from Belkin and other vendors. The device is accessed through the ucom(4) driver which makes it behave like a tty(4).
HARDWAREThe ubsa driver supports the following adapters: · AnyData ADU-500A EV-DO modem · AnyData ADU-E100A (no EV-DO mode support) · Belkin F5U103 · Belkin F5U120 · e-Tek Labs Kwik232 · GoHubs GoCOM232 · Peracom single port serial adapter
FILES/dev/ttyU* for callin ports /dev/ttyU*.init /dev/ttyU*.lock corresponding callin initial-state and lock-state devices /dev/cuaU* for callout ports /dev/cuaU*.init /dev/cuaU*.lock corresponding callout initial-state and lock-state devices
SEE ALSOtty(4), ucom(4), usb(4)
HISTORYThe ubsa driver appeared in FreeBSD 5.0. The uplcom(4) manual page was adopted from NetBSD by Tom Rhodes <@FreeBSD.org> in April 2002 and modified for the ubsa driver by Alexander Kabaev <@FreeBSD.org> in October 2002.
AUTHORSThe ubsa driver was written by Alexander Kabaev <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|ubsa(4freebsd)||referred by||ucom(4freebsd) | umct(4freebsd)|
|refer to||tty(4) | ucom(4freebsd) | uplcom(4freebsd) | usb(4freebsd)|