UMCT(4FREEBSD) - Linux man page online | Special files
Magic Control Technology USB-RS232 converter driver.
April 26, 2017
UMCT(4) BSD Kernel Interfaces Manual UMCT(4)
BSD April 26, 2017 BSD
NAMEumct — Magic Control Technology USB-RS232 converter driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device usb device ucom device umct Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): umct_load="YES"
DESCRIPTIONThe umct driver provides support for USB to RS-232 converters based on the Magic Control Technology USB-232 design. These devices support most of the standard RS-232 features including baud rates ranging from 300 to 115200 bits per second. However, neither hardware nor software flow control seems to be supported. Access to devices under this driver is via the ucom(4) framework and device nodes.
HARDWAREThe umct driver supports the following adapters: · Belkin F5U109 · Belkin F5U409 · D-Link DU-H3SP USB BAY Hub · Magic Control Technology USB-232 · Sitecom USB-232
FILES/dev/ttyU* for callin ports /dev/ttyU*.init /dev/ttyU*.lock corresponding callin initial-state and lock-state devices /dev/cuaU* for callout ports /dev/cuaU*.init /dev/cuaU*.lock corresponding callout initial-state and lock-state devices
SEE ALSOtty(4), ucom(4), usb(4)
HISTORYThe umct driver appeared in FreeBSD 5.2. It is loosely based on the ubsa(4) driver by Alexander Kabaev <@FreeBSD.org> with documentation from Wolfgang Grandeggar <@cec.ch>.
AUTHORSThe umct driver was written by Scott Long <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||tty(4) | ubsa(4freebsd) | ucom(4freebsd) | usb(4freebsd)|